Categories
Unix

The Fix for those Silly FreeBSD PHP Ports PHP_AUTOCONF Errors

If you’ve also been running into those PHP_AUTOCONF errors when trying to build php modules on FreeBSD, then you’ll be interested in this. The following two commands fixed the problem for me:


ln -s /usr/local/bin/autoheader-2.59 /usr/local/bin/autoheader259
ln -s /usr/local/bin/autoconf-2.59 /usr/local/bin/autoconf259

The error message I was getting is as follows:

Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF environment variable is set correctly and then rerun this script

05-October-2007 Update

If you’re seeing this problem again with autoconf 2.61 and php 5.2.4 on FreeBSD 6.2, the new fix is to run these commands (assuming you are using a c shell):


setenv PHP_AUTOCONF autoconf-2.61
setenv PHP_AUTOHEADER autoheader-2.61

By George Donnelly

I'm building a tribe of radical libertarians to voluntarize the world by 2064. Join me.

10 replies on “The Fix for those Silly FreeBSD PHP Ports PHP_AUTOCONF Errors”

Thanks. I needed this tip. Here is a small improvement:

setenv PHP_AUTOCONF autoconf
setenv PHP_AUTOHEADER autoheader

Regards,
OE

I saw the same error while installing PHP, but then I understood that this is not a problem with freebsd ports.

What I did next was: “pkg_info | grep php”
There was php5-5.1.6_3 package already, so I did “pkg_delete php5-5.1.6_3” and started “make install clean” in the ports folder. The port was installed smoothly.

I am configuring ffmpegphp on my domain mysolutions.phonecare.in.
I downloaded the file and unzipped in home/mysolutions.phonecare.in/ffmpeg-php-0.5.0
Now when I try to run phpize, I get this error “Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF
environment variable is set correctly and then rerun this script.”

Thanks X!
made the manual links before, but still errors using portupgrade
setenv PHP_AUTOCONF autoconf
setenv PHP_AUTOHEADER autoheader
did the trick for me too!!

hello to all
i am also facing problem from PHP_AUTOCONF and also tried to suggestion ,but i still have problem
please any one help me

Leave a Reply

Your email address will not be published.